Home Forums Development Can anyone please help with following error?

Ce sujet a 4 réponses, 3 participants et a été mis à jour par  AngelaIp, il y a 9 mois.

5 sujets de 1 à 5 (sur un total de 5)
  • Auteur
    Messages
  • #11162

    Mily
    Participant

    Name cannot begin with the ‘6’ character, hexadecimal value 0x36. Line 1, position 56.<SOAP-ENV:Envelope xmlns:SOAP-ENV=”http://schemas.xmlsoap.org/soap/envelope/”><SOAP-ENV:Body><SOAP-ENV:Fault xmlns:af=”http://www.aras.com/InnovatorFault”><faultcode>SOAP-ENV:Server</faultcode><faultstring><![CDATA[Name cannot begin with the ‘6’ character, hexadecimal value 0x36. Line 1, position 56.]]></faultstring><detail><af:legacy_detail><![CDATA[Name cannot begin with the ‘6’ character, hexadecimal value 0x36. Line 1, position 56.]]></af:legacy_detail><af:exception message=”Name cannot begin with the ‘6’ character, hexadecimal value 0x36. Line 1, position 56.” type=”System.Xml.XmlException”/></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

    #11165

    Yoann Maingon
    Admin bbPress

    Tough to help you.

    Can you give us more info? when it happens?

    #11183

    Mily
    Participant

    //I have written tis method to disable user its totally fine but it is showing this character error?

     

     

    Innovator inn = this.getInnovator();

    string aml= “<AML>”+
    “<Item type=’User’ action=’get’>”+
    “<created_on condition=’between’>2018-01-01 and 2018-01-31</created_on>”+
    “</Item>”+
    “</AML>”;

    Item res = inn.applyAML(aml);

    string amlQuery=”<AML>”+
    “<Item type=’User’ action=’edit’ where='[User].id=’6125ABB3D2754E31A5E2166F42FEE7A0”>”+
    “<logon_enabled condition=’eq’>0</logon_enabled>”+
    “</Item>”+
    “</AML>”;
    Item result =inn.applyAML(amlQuery);

    return this;

    #11186

    Mily
    Participant

    This error is seems so irrelevant and i want to resolved it soon .one of my friend has done same method but its running successfully.please help

    #11193

    AngelaIp
    Participant

    Hi Mily,

    I think your problem are the quotation marks. Try to use a string builder instead defining the id in the where clause.

    Something like this (not tested):

    String aml = @"<AML><Item type='User' where='[User].id={0}' action='edit' /></Item></AML>";        
    aml = String.Format(aml, /* your id */ );
5 sujets de 1 à 5 (sur un total de 5)

Vous devez être connecté pour répondre à ce sujet.