Quality Module Install error

I'm trying to assess the suitability of using Aras for Quality Management in my organization and am unable to install that module.  I've installed successfully Innovator 12 and the sample database; however, when I go to install the Quality module from the Aras Update utility it fails with the error at bottom.

I've looked on the forum but cannot find similar failures.  Any help that anyone can provide would be greatly appreciated.




Import package 'com.aras.innovator.solution.QMS_QS' failed with message:

Server error

Request: <Item type="Identity" id="CA6D245B9B224A6288F056B33E02097E" action="add" doGetItem="0"><description>Quality Department</description><is_alias>0</is_alias><name>Quality</name><Relationships /></Item>

Responce: <SOAP-ENV:Envelope xmlns:SOAP-ENV="">schemas.xmlsoap.org/.../"><SOAP-ENV:Body><SOAP-ENV:Fault xmlns:af="">www.aras.com/.../faultcode><faultstring><![CDATA[Identity with Name 'Quality' already exists.]]></faultstring><detail><af:legacy_detail><![CDATA[Identity with Name 'Quality' already exists.]]></af:legacy_detail><af:exception message="Identity with Name 'Quality' already exists." type="Aras.Server.Core.PropertiesAreNotUniqueException"><af:innerException message="Violation of UNIQUE KEY constraint." type="Aras.Server.Core.DBUniqueConstraintViolationException"><af:innerException message="Violation of UNIQUE KEY constraint 'C5'. Cannot insert duplicate key in object 'innovator.IDENTITY'. The duplicate key value is (Quality).&#xD;&#xA;The statement has been terminated." type="System.Data.SqlClient.SqlException" /></af:innerException></af:exception><af:item type="Identity" id="CA6D245B9B224A6288F056B33E02097E" xpath="Item"><af:property name="name" value="Quality" /></af:item></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>
Updating com.aras.innovator.solution.QMS_QS to failed release status


  • Hi 

    Can you confirm the type option selected in your import tool. Try merge option if you have used ignore

    Thank You

    Gopikrishnan R

  • Hi Gopikrishnan, thank you for your reply.  I don't see the option you've screenshotted in the update tool for Innovator 12.  May I ask where/how you brought up this menu?

  • Hi

    Try manually importing the module.

    Open ARAS Update tool 

    Navigate to required Package to be installed (In this case, ARAS Quality Management System)

    Select version and click download instead of Install

    Navigate to downloaded folder (mostly C:\ProgramData\Aras\ArasUpdate\QMS\12.0.1171\PackageImportExportUtilities\Import)

    Run import.exe

    Fill the details as below (select correct import.mf file path)

    Click Import 

    Let me know if you are still facing the issue.

    Thank You

    Gopikrishnan R

  • Thank you so much for your detailed reply! I tried those steps and get two dialog boxes at the end of the process.  These seem to be same error(s) as copied in-line above.  But perhaps they're a red herring?

    I say that because, upon further review, from comparing the very useful image you provided against the existing packages listed for the Sample Database, it seems like it may be fully installed -- or at least fully loaded from the sample database -- but not all of the features are visible on the site (and connected to the sample database).  Specifically missing are the Quality Systems elements (e.g., CAPA, RCA)...

    How do I check that the install is fully complete?  If it is fully complete, how do I enable these features?

    Thanks again for your help!!


  • Hi Keith

    From your screenshot, I can understand QMS is partially installed in system. Follow below steps and let me know how it behaves

    Navigate to downloaded folder (mostly C:\ProgramData\Aras\ArasUpdate\QMS\12.0.1171\Imports\QMS\Import\QMS_QS\Identity)

    Open Quality.xml in notepad++

    Change action="merge" from action="add"

    Save and Close File

    Follow the same manual install steps (follow the steps in my previous reply)

    Thank You

    Gopikrishnan R

  • Hi Gopikrishnan,

    Thanks for your rapid reply.  I updated the file and changed all instances of add to merge, and am now getting a different error message.

    This seems to be failing on UPDATE rather than INSERT, so at least it's actually attempting to merge it this time. Does this indicate anything to you?  Might you have any further suggestions about what to try next?  Many thanks for all your help!!

    Best regards,


  • Hi Keith

    Can you check the installation document in this folder. Check are you missing any steps. Also there are steps for manual installation.


    Thank You

    Gopikrishnan R

  • I'll do that (again). This seems particularly odd since I'm using a fresh install of the latest release of Innovator and it's the official sample database that I'm trying to update -- this is the definition of plain vanilla.

    I'd love to know what tables these database errors are referring to since it seems these errors might be easily resolved by deleting the record(s) that are causing the constraint violation. Any suggestions there?

  • You can navigate to Administrators --> Identity --> Search for Quality and try deleting it in UI

  • Hi again Gopikrishnan,

    Thanks for that suggestion, I'll give it a shot.  To confirm I understand, I should right click on the Quality record and select Delete All Versions, is that correct?

    Without your assistance I'd still be completely lost -- instead of mostly lost ;) -- and even more frustrated. Thank you very much!!