rror: Cannot access OAuth Server due to 502 (Bad Gateway)

Hi all

I'm trying to fresh install Innovator to try remedy other errors with the previous install. I keep getting this error "Error: Cannot access OAuth Server due to 502 (Bad Gateway)" even after installing the prerequisites for Innovator 12. I also get an error with chrome saying that it failed the minimum browser check, even though I have chrome 79

Any suggestions?

Thanks, Duncan

Parents Reply Children
  • I am getting the same problem as the OP. Originally it was the 500 Error, however after installing the correct version of ASP.NET Runtime Core (Hosting) it then changed to the 502 Error.

    I believe I have installed the correct versions of all the relevant software;

    It is a new install on a Windows Server 2019 and SQL Server 2017 machine, which I realise is outside the normal specs.

    Any ideas on how to debug this further, or anything else to try?

  • Stuck in the same place, same steps as you. Any ideas?

  • I am having the same issue.  I originally had the 500 error because I didn't have the hosting version installed.  I now have the same 4.7.2 SDK and 4.8 .net framework installed.  I tried installing the regular version of .net frameword 4.7.2 installed, but it says I have a newer version.

    MS Server 2016

    MS SQL server express 2019

  • Hi All,

    There are a couple more things you can double check. Do you have the Microsoft Visual C++ Redistributable 2015 installed? Is your system environment path variable pointing to sql server and dotnet? 

    Best,

    Nithin

  • I have C++2015 redistributable.  I had to uninstall c++ 2017 redistributable to install it. 

    What locations should the path be pointing to?  I have 4.2.7 installed and located at 

    C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\.NETFramework\v4.7.2\

    What else am I missing?

  • Hi Wiwalsh,

    Does your program files have "dotnet", for example "C:\Program Files (x86)\dotnet" and "C:\Program Files\dotnet?" Add those to your path variables. Another thing you can confirm is that your instance agent services are running.

    Hope this helps!

    Best,

    Nithin

  • I have the following service

    "ArasInnovatorAgent_ArasInnovatorAgent1"

    which points to 

    "D:\Aras\Innovator\AgentService\Aras.Server.Agent.Service.exe"

    that executable does not exist, so the service is unable to start.  Any ideas?

  • I modified the installation and now have that service running, same 502 error.  What other services should be running?

  • Hi Wiwalsh,

    You have ASP.NET core/.NET Core: Runtime and Hosting Bundle version 2.1.8 and .NET Framework 4.7.2 correct? You can find the download for ASP.net at this link and .NET Framework from here 

    Best,

    Nithin