First-time login: Invalid object name 'LOCALE'.

We have tried to install ARAS Innovator 12.0 on a PC a few times over the last couple of days and have hit various different errors when trying to login.

This time, I decided to delete the InnovatorSolutions DB that was created by the first install and have the install process recreate it.  Now, when trying to log in with admin/innovator for the first time, I get the error "Invalid object name 'LOCALE'."

How can I troubleshoot this?  Is there any additional information I should post?


  • Same problem, but different setup. I wanted a 12 and 11 both on the same machine. I had it all working, but I had 12 installed all with defaults and then 11 with tacked-on "11"s everywhere. When writing a guide I decided it should approach at the least different versions on the same system. So, I uninstalled both versions, deleted the associated DBs, and re-installed where both used settings that included the version number (folder locations, paths, vault folder, etc. - db users, everything). I can log into 12 right away w/o issue. 11 shows this error when attempting to log in... I've not found my answer in this thread, but will comment when I do.

  • As you can see, my 12 has a ton more tables. These do include "innovator.LOCALE". My Innovator11 db includes none of these. I've tried re-installation of 11 to no avail. Section 8 of the guide didn't shed any light on this problem.

  • I meticulously walked through the mess using Microsoft SQL Server Manangement Studio, as Admin, and deleted any reference to my innovator11 and innovator_regular11 users. I also deleted my InnovatorSolutions11 db altogether. Again, reinstalling, I saw this for the first time doing 11. Before it just kinda hung awhile, no feedback, I thought that was just a UX improvement between 11 and 12...

  • viola... so, I guess my solution was super full cleanup using MSSMS - that's all references to my 11 install users - I got a warning when doing the reinstall and had to goto: Databases > System Databases > master > Security > Users, and then delete my innovator11/innovator_regular11 users there too. Just pointing that out. I think we should move all this to Stack Overflow in some sort of Aras channel. It'd be great to feel like there was actual community around this, and was support. This was a real pain in the ass.

    NOTE: I DO see this stuff now:

  • Use the MS SQL Management Studio to see if there is a table under your db, "innovator.LOCALE".

    PATH: Databases > YOUR_DB_NAME (default InnovatorSolutions) > Tables:

    Mine were not there so I had to meticulously remove users from previous install attempts, also using MSSMS, throughout the DB, and reinstall.

    Of course, this is way late. Just hoping to help the next person stuck here...

  • Hey Neil, 

    Kind of same thing on my end.  I had to bring in a colleague that had more experience with server database management, he did a very thorough manual deleting of old database traces, and then I was able to get a working new install.  It is frustrating that ARAS does not remove these traces in its included uninstall, and I still don't know what really went wrong on the first once, nor do I know what specific part of the old installs were causing the issue.

    All I can say to people reading this from Google is - do a very thorough removal of old databases through a SQL server manager.  This seemed to work for me.

  • NOTE: My dual install dev system is looking good now... both reachable.

    NOW, I've my token, but how to use it with PostMan to do some AML w/o this darn 405!?

  • Thank you for sharing this. Seems we found a solution! :)