First-time login: Invalid object name 'LOCALE'.

We have tried to install ARAS Innovator 12.0 on a PC a few times over the last couple of days and have hit various different errors when trying to login.

This time, I decided to delete the InnovatorSolutions DB that was created by the first install and have the install process recreate it.  Now, when trying to log in with admin/innovator for the first time, I get the error "Invalid object name 'LOCALE'."

How can I troubleshoot this?  Is there any additional information I should post?


  • Hey Chris, 

    I am still encountering the same error.  Can you take a look at the permissions in my previous reply and let me know if anything looks wrong?


  • Hello,

    I compared the screenshots you sent me with the settings on a 12.0 database I have set up locally. I'm seeing a difference in that the users in my database don't have db_accessadmin membership. I'm not sure this alone would cause the issue, but it does indicate that these users were configured differently than expected.

    Can you confirm that you have administrative access on the machine running SQL Server? When you run the installer, are you configuring the database using Windows Authentication credentials or with the built in sa SQL Server user?


  • I tried unchecking db_accessadmin but that did not change anything.  I used Windows Authentication credentials and do have admin access to the server.

Reply Children