License key not accepted in new ARAS Innovator 12 installation

I tried to install Aras Innovator 12.0 according to the book, but I always get "You must enter valid License Key"

I want to install on a virtual Windows server and I already requested a license twice, first for the default VMWare generated MAC address and then for a static assigned MAC address in VMWare workstation. Always with the same result.

I verified the MAC address with ipconfig and according to documentation everything is OK.

And I selected the correct Aras version  for the license request, i.e. 12.

  • Hi Otto,

    I've looked at your license, and I'm not seeing any issues with either one you've generated. Could you verify that you're entering in the full text of the license key (i.e. the entire line below)?

    <License lic_type="Unlimited" lic_key="..." act_key="..."/>

    And not just the value of the lic_key attribute?


    Christopher GIllis

    Aras Labs Software Engineer

  • Hi Christopher,

    quick response, thank you. Of course I added the full XML content, copy & paste from the email, with and without the comment. And I even copy& pasted only the lic_key and act_key values to the initial template of the installer.

    Could the type of network interface make a difference? Is the MAC address somehow validated online? I am using NAT for the VMWare network interface, not bridged. So I have a MAC address of the VMWare host talking to to external world and a VMWare MAC address of the guest.

    And to  anticipate a question: No, I cannot use bridged  for this virtual server.

  • That would be my guess, but I don't have much experience with setting up Innovator on VMs. If you open up a command prompt on the VM and type ipconfig /all , you should see a list of all of the MAC addresses of the VM. 

    Did you manually enter in the MAC address when you requested the license? If so, could you try to request one from the Aras Innovator installer. On one of the first pages, there should be a Request button. Clicking that will take you to the license request web page and automatically populate the MAC address field.

  • I requested the license from the Installer. When it opened the Web page for license request, the MAC address was pre-filled and also the Aras Innovator version. This version was set to 11.0.0 and I couldn't change it. With that generated license the Installer continues.

    I am using InnovatorSetup_12.0.msi and when I manually requested the license, of course I selected version 12. So the problem is that installer for version 12 expects a license for version 11.

  • After installation I checked the version and it says 11.0 SP12 Build: 6920. As said, I used InnovatorSetup_12.0.msi, downloaded 2019-06-28. I downloaded again and now the MSI installer has a different size. Installation over the existing version does not work. So now I first have to uninstall the old version and try a new installation.