Aras Innovator Installation

Hallo everyone,

I am having trouble installing the Aras Innovator.

Here is what I am using:

- Administrator Logon Access to IIS Server (Virtual Server)

- SQL Express Installation with admin privileges

- License Key issued from Aras

I used the complete installation method as mentioned in this tutorial video:

The Client used is the server as well in this case.

However I cannot complete the installation progress with the settings, that were put in when "Configure Database" appears.

Here is what I have to choose:

- Database Server: I am using a created Database Server called "DLS"

So it looks like: Database Server: (local)\DLS

When selecting "Create a new database" at Configuration Options, I have to choose

"Server authentication using the Login ID and password below" afterwards.

When selecting Login ID I put in: sa

When selecting Password I put in: Password2018!

as selected when creating the login and password. After selecting "Connect..." the next

options to choose are Database Login Options. Here I choose the following Logins:

DB owner login: innovator

Password: Password2018!

DB client login: innovator

Password: Password2018!

as created in SQL Express

After selecting Configure Database a window pops up: Database InnovatorSolutions already exists.

So then I tried using the option "Populate an exisiting database" in the configuration options. I chose connect for the databse login options and then configure database.

Like in the tutorial video the window says: The Innovator database will be installed and configured now. Would you loke to proceed?

After choosing "Yes" the following window pops up: It is required that populated database should have user with name "innovator_regular". This user must be associated with any login in SQL Server.

So then I tried "Use an existing database" in the configurations options. After selecting The innovator database will be installed and configured now. Would you like to proceed? I chose Yes.

After that I can choose Next at the bottom and afterwards "Install". Setup completes and then there a few security settings which need to be selected in the browsers. After that I user the Set .Net Security Tool and choose the URL for the Aras Innovator Installation mentioned in the tutorial video. The log file shows success.

Now when trying opening the link localhost... which is also mentioned in the tutorial video the browser shows the following:

HTTP Error 404.0 - Not Found

Can you help me now? What can I do to successfully test the IE / Mozilla browser?

  • Hi Sebastian,

    I have a few questions/suggestions.

    1. Which version of Aras Innovator are you trying to install?

    2. Was the InnovatorSolutions database created within your SQL server instance?

    3. When creating a new database your input for "DB Client" should be innovator_regular. By default, all regular database requests from Aras Innovator are executed on behalf of the innovator_regular database user. Assigning this value to the innovator role will cause issues, as all innovator SQL requests would have owner permissions.

    I would recommend attempting a clean install. To create a new database you'll need to erase your old InnovatorSolutions, or create a completely new DB with a different name. Once install is complete you'll navigate to localhost/<your web alias> and you should be able to access the Innovator server. 


  • Hello AJ,

    1. I am using the current version of Aras Innovator 11.0 SP12

    2. No the InnovatorSolutions database was not created within the SQL server instance.

    3. I am very new to SQL Express... So maybe you can also help me to create a new database there?
    Because I already tried a lot to create a new one but didn't know how.

  • Could you please try reinstalling Aras Innovator, creating a new database through the installer. The image below shows how you should configure your environment, ensure you're creating a new database, and innovator_regular is being set as the DB Client user. 

  • This window appears (It's german sorry) I hope you can understand a bit of it. It says: Access denied. I have tried it with the password which was set for the user sa.

    It says: SQL Server doesnt exist. Access denied.

    It's german language.

    The user was set to: sa

    and the password was: Password2018! 

    as set in the settings.

  • It looks like you'll want to set the database server to (local)\DLS or whatever your existing server is. Sorry for not mentioning that. 

  • 1.As you can see my current database is named DLS

    I don't know how to erase this one and to create a new one. Can you help me there?

    Still the Aras Innovator setup says Database InnovatorSolutions already exists when trying to configure Database.

    When leaving the Password fields empty this error message appears.

    I know it might be caused by the DLS database now. But I already tried searching in google how to erase the current database... So I need help here...

  • Okay now I managed to reinstall the whole SQL Express Installation. Now I named the new database "NEU". When clicking on Configure database, the following window appears:

  • Now I deactivated the complexity of the password policy. And I got it to work.

    After the installation was finished I started the Internet Explorer with the link described in the tutorial video.

    Now the following error message comes up:

  • Hi Sebastian,

    I can't read german, so apologies in advance. You'll want to ensure you add passwords for both the innovator and innovator_regular users.

    You won't be able to add a new innovator solutions db to either sql environment. To add a new database you'll have to delete the existing innovatorsolutions DB, which you can accomplish by opening SSMS and right clicking your InnovatorSolutions DB and selecting delete. You could also create a database with a new name within the install process.

    I would recommend trying to use this guide, as I've used this guide successfully.

    What url are you using to access your instance from the browser? The error you're getting happens when you're attempting to access a URL which is not associated with Innovator.

  • I finally got it to work. Thanks a lot for your support!