Trouble with browser (IE, Chrome, Firefox, Edge)

Hi all We just started with ARAS and are already struggeling with our browser settings. No matter which browser I'm using I always see only half of the properties. I worked through all the settings I found on the ARAS website (link below) but they don't seem to work. www.aras.com/.../ We have ARAS 11.9 installed and added the Minerva add-in for medical devices. I as the administrator have may problems setting up the browsers. I really can't imagine setting up all client computers manually to meet the ARAS requirements. There should be an easier way to use ARAS. Any advice? Thanks Chris
  • Hi Chris, I'm not quite sure what you mean when you say you "always see only half of the properties". Could you elaborate on this behavior? Could you also let us know which browser(s) you are using? Chris
    Christopher Gillis Aras Labs Software Engineer
  • Hi Chris I've created a new item type called purchase request for our internal purchase process. I've also created a new form and two lists which I wanted to assign to the item type. Sometimes when I open the item type I only see the top part containing the name of the item typ, singular and plural label and so on. On Monday I was able to see the lower part too. The part that contains the relationship types, properties, TOC access and so on. Today I couldn't see the lower part of the item type information. I also couldn't add any information to my lists because the lower part to add texts was missing there too. I would have added a screenshot to the thread but it seems as if there is no such function in this forum. I'm currently trying to work with Firefox build 62.0.3 (64-Bit), Chrome 69.0.3497.100 and Edge 42.17134.1.0. Edge seems to be the only browser that's working. At least sometimes. Right now, without changing anything - I haven't closed the browser for the last six hours, I can see the lower part if the item type. It's currently working (for 20 minutes). I have no idea why and if this will be true for the next hour. The support documentation provided by ARAS is not very helpful - neither for setting up the browsers nor the handbook on creating new item types and workflows - which is very unsatisfying, especially after paying for A VERY HIGH subscription fee. Thanks for the support. Chris
  • From the description of the issue, it doesn't sound like this would be caused by any of the browser settings. With the release of 11.0 SP9, we focused heavily on minimizing the amount client-side configuration required to get Aras Innovator up and running. I haven't seen this exact behavior before, but seeing as you're a subscriber, I'd recommend contacting our Support team (support@aras.com) with this issue. They'll be able to more easily troubleshoot this with you. One final thing to note is that only the Extended Support Releases (ESR) of Firefox should be used with Aras Innovator. We recommend using ESR 45 or ESR 38 with Aras Innovator 11.0 SP9. Chris
    Christopher Gillis Aras Labs Software Engineer
  • Thank you Chris. I will contact the support team and install one of the recommended Firefox.