Help Me Get This Running Please!

Sadly, I've been working on a Basic / Test install for 2 days now... I'm getting very disappointed... Not easy to install at all.

The documentation provided at https://www.aras.com/en/support/documentation did not include detailed requirements for the Server, what IIS components are required or anything. That set me back the first day.

I found this site that outlined it very better, FYI- https://www.razorleaf.com/blog/aras-innovator-installation-lets-make-this-easy/

I installed everything (I think), and the installer goes through, creates the database, and completes

All I get is that the content is being blocked. Its in the 'Trusted Sites' but it still doesn't work... Tried Chrome, still not working, not sure what to do next... Any idea what settings might fix this? 

--- EDIT ---- 

Ugh I'm back to this other terrible error, it won't start up IIS

The internet just says restart the service, but it fails 

The only way to get IIS to start up again is to delete everything under 'default web site', something is wrong there. 

Any help would be gladly appreciated

Parents
  • OK so some more information. 

    I just started over completely, got it so it looks like everything went well. Went berserk with giving rights to the inetpub folder to anyone and everyone that wanted it. Set all users rights to me, as I'm an admin on the machine. 

    I got it to budge, my tinkering with the applicationHost.config file, it was crashing on the <system.web> sections. By removing these it at least compiles 

    <location path="Default Web Site/InnovatorServer/OAuthServer">
    <system.web>
    <authentication mode="Windows" />
    </system.web>
    <system.webServer>
    <handlers accessPolicy="Read, Script" />
    <directoryBrowse enabled="false" />
    <asp>
    <session timeout="00:20:00" />
    <limits scriptTimeout="00:01:30" />
    </asp>
    <security>
    <authentication>
    <anonymousAuthentication enabled="true" />
    <basicAuthentication enabled="false" />
    <windowsAuthentication enabled="false" />
    </authentication>
    </security>
    <httpLogging dontLog="false" />
    <defaultDocument>
    <files>
    <clear />
    <add value="Default.htm" />
    <add value="Default.asp" />
    <add value="index.htm" />
    <add value="index.html" />
    <add value="iisstart.htm" />
    <add value="default.aspx" />
    <add value="default.html" />
    </files>
    </defaultDocument>
    </system.webServer>
    </location>


    <location path="Default Web Site/InnovatorServer/Vault">
    <system.web>
    <authentication mode="Windows" />
    </system.web>
    <system.webServer>
    <handlers accessPolicy="Read, Script" />
    <directoryBrowse enabled="false" />
    <asp>
    <session timeout="00:20:00" />
    <limits scriptTimeout="00:01:30" />
    </asp>
    <security>
    <authentication>
    <anonymousAuthentication enabled="true" />
    <basicAuthentication enabled="false" />
    <windowsAuthentication enabled="false" />
    </authentication>
    </security>
    <httpLogging dontLog="false" />
    <defaultDocument>
    <files>
    <clear />
    <add value="Default.htm" />
    <add value="Default.asp" />
    <add value="index.htm" />
    <add value="index.html" />
    <add value="iisstart.htm" />
    <add value="default.aspx" />
    <add value="VaultServer.aspx" />
    </files>
    </defaultDocument>
    </system.webServer>
    </location>

    Here is the error

    The Windows Process Activation Service encountered an error trying to read configuration data from file '\\?\C:\Windows\system32\inetsrv\config\applicationHost.config', line number '1161'. The error message is: 'The configuration section 'system.web' cannot be read because it is missing a section declaration
    '. The data field contains the error number.

    Now it gives me fun circle that never loads. How do I resolve this? 

Reply
  • OK so some more information. 

    I just started over completely, got it so it looks like everything went well. Went berserk with giving rights to the inetpub folder to anyone and everyone that wanted it. Set all users rights to me, as I'm an admin on the machine. 

    I got it to budge, my tinkering with the applicationHost.config file, it was crashing on the <system.web> sections. By removing these it at least compiles 

    <location path="Default Web Site/InnovatorServer/OAuthServer">
    <system.web>
    <authentication mode="Windows" />
    </system.web>
    <system.webServer>
    <handlers accessPolicy="Read, Script" />
    <directoryBrowse enabled="false" />
    <asp>
    <session timeout="00:20:00" />
    <limits scriptTimeout="00:01:30" />
    </asp>
    <security>
    <authentication>
    <anonymousAuthentication enabled="true" />
    <basicAuthentication enabled="false" />
    <windowsAuthentication enabled="false" />
    </authentication>
    </security>
    <httpLogging dontLog="false" />
    <defaultDocument>
    <files>
    <clear />
    <add value="Default.htm" />
    <add value="Default.asp" />
    <add value="index.htm" />
    <add value="index.html" />
    <add value="iisstart.htm" />
    <add value="default.aspx" />
    <add value="default.html" />
    </files>
    </defaultDocument>
    </system.webServer>
    </location>


    <location path="Default Web Site/InnovatorServer/Vault">
    <system.web>
    <authentication mode="Windows" />
    </system.web>
    <system.webServer>
    <handlers accessPolicy="Read, Script" />
    <directoryBrowse enabled="false" />
    <asp>
    <session timeout="00:20:00" />
    <limits scriptTimeout="00:01:30" />
    </asp>
    <security>
    <authentication>
    <anonymousAuthentication enabled="true" />
    <basicAuthentication enabled="false" />
    <windowsAuthentication enabled="false" />
    </authentication>
    </security>
    <httpLogging dontLog="false" />
    <defaultDocument>
    <files>
    <clear />
    <add value="Default.htm" />
    <add value="Default.asp" />
    <add value="index.htm" />
    <add value="index.html" />
    <add value="iisstart.htm" />
    <add value="default.aspx" />
    <add value="VaultServer.aspx" />
    </files>
    </defaultDocument>
    </system.webServer>
    </location>

    Here is the error

    The Windows Process Activation Service encountered an error trying to read configuration data from file '\\?\C:\Windows\system32\inetsrv\config\applicationHost.config', line number '1161'. The error message is: 'The configuration section 'system.web' cannot be read because it is missing a section declaration
    '. The data field contains the error number.

    Now it gives me fun circle that never loads. How do I resolve this? 

Children
  • This is the error

    The Windows Process Activation Service encountered an error trying to read configuration data from file '\\?\C:\Windows\system32\inetsrv\config\applicationHost.config', line number '1161'. The error message is: 'The configuration section 'system.web' cannot be read because it is missing a section declaration
    '. The data field contains the error number.

  • Wow did I do a lot of unnecessary stuff. Figured it out, it was that the instructions didn't accurately explain WHICH .net core link to install. I installed the SDK, not the 'hosting bundle', it HAS to be the hosting bundle 

  • Oh dear,

    Aras should pay all affected users compensation for spending hours for fixing this bug.

    Had it too, spend several hours for a fix-> https://community.aras.com/f/getting-started/35869/installing-aras-kills-iis

    The hosting bundle might fix the problem, but not the root cause -> Aras´ strategy to spend more money on marketing than on their quality department. Glad you were able to fix this one!

    Which Aras version did you use? I haven´t seen this error in 12SP3, but faced it in 12SP7.