Installation Of Aras 12SP9 stops ISS

Hi All,

I just started anew install of Aras 12 SP9 on a new PC for development work, The PC is a HP Z workstation, running Windows 10 pro, having enabled ISS and checked that worked by going to Chrome localhost it displayed its standard default page. I atempedted to installed  .NET 4.7.2 but found it did not like it and said a later version was already installed. So I went on with the install process I had previously installed MS SQL Server Express.  After the basic install I was not able to get to localhost, IIS (Internet Information Services manager) and found that it was not running, so I tried to start it and was given the 

"Cannot start service W3SVC on computer"

I found a stackoverflow article, which suggested that I should remove ISS using "Turn Windows Feature on or off" so I removed ISS restarted pc, when and renabled ISS and I had a working version of ISS. This of cause removed configuration that Aras had placed in within ISS.

So I uninstalled Aras, and  having searched around and found that there was a dev version .NET 4.7.2 so I installed that thinking maybe that was the issue. I reinstalled Aras  the issue I found was that the Aras Innovator Agent had not been removed by the uninstall process, so I had to rename it. I was then able to reinstall it, but again the it stops ISS and now I have 2 Aras Innovator Agent services , AgentService_InnovatorServer and AgentService_Innovator12 my renamed service from my second install,

Again my ISS stopped working with the W3SVC error. 

Does anyone know what the cause of this W3SVC error and how I can get rid of one of the Agent services as I am sure I only need one.

  • For your reference, the IIS not working issue occurs due to installing the prerequisites in the incorrect order. Please follow the steps below to resolve that: 

    1. Uninstall the following to ensure a clean server
      1. Aras Innovator
      2. IIS
      3. Microsoft Visual C++ Redistributable 2015
      4. .Net .Net Framework 4.7.2
      5. Microsoft .NET Core Runtime – 2.1.8
      6. Microsoft .NET Core 2.1.8 – Windows Server Hosting
    2. Install IIS using the following steps (you will receive 500.19 error if you do not select the features below):
      1. .NET Framework 4.5 Advanced Services
    1. Windows 8 / WS2012 or higher
    2. For lower OS versions, .NET 4.0 or 4.5 must be installed separately

     

      1. Static Content
      2. Windows Authentication
      3. ASP
      4. ASP.NET 4.5
    1. Windows 8 / WS2012 or higher
    2. Just “ASP.NET” in lower OS versions

     

     

    1. Install the following prerequisites (in the order listed):
      1. Microsoft Visual C++ Redistributable 2015
      2. .Net .Net Framework 4.7.2
      3. ASP.Net Core/.NET Core Runtime and Hosting Bundle 2.1.8
    2. Install Aras Innovator 12.0 SP6 using the steps outlined in the Aras Innovator Installation Guide
  • I will try this and let you know how it goes, is there any reason to install 12.0 SP6 rather than the SP9 version ?

    After trying all of the above a few times, i.e. deleting them and reinstalling them  and adding aspnetcore-runtime-2.1.21-win-x64 it finally appears to work.

    Thank for all the help, one question does .NET have a dependancy checker program.