Configuration file missing when adding SP9 as a reference package in Aras Update

Hi

I get an error when adding the new SP as a reference file to Aras Update to upgrade Innovator. 

"Configuration file missing in path G:\ ... package.config"

Must I extract the Zip within the Aras install folder (x86)?

Parents Reply Children
  • Apologies, I get this incompatibility error when pointing to the correct directory:

    2020-08-24 19:23:32,547 [9] INFO Aras.Tools.ArasUpdateGui.Logger Checking package started: 'G:\Aras\CD Images\12.0 SP9 CD Image\Utilities\package.config'
    2020-08-24 19:23:32,576 [9] INFO Aras.Tools.ArasUpdateGui.Logger Checking package finished
    2020-08-24 19:23:33,375 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,443 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,507 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,575 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,643 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,707 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,770 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,831 [9] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2020-08-24 19:23:33,920 [9] WARN Aras.Tools.ArasUpdateGui.Logger Custom check failed.
    2020-08-24 19:23:33,942 [9] WARN Aras.Tools.ArasUpdateGui.Logger Custom check failed.
    2020-08-24 19:23:33,957 [9] ERROR Aras.Tools.ArasUpdateGui.Logger Aras.Tools.ArasUpdateCore.Implementations.Commands.CheckCompatibilityPackageCommand: Custom check failed.Custom check failed.
    2020-08-24 19:23:33,958 [9] INFO Aras.Tools.ArasUpdateGui.Logger Operation 'Install' failed

  • Hi Duncan,

    I am sorry I think I told you it needs to point to the Innovator folder within the directory, but it should just be pointing to the top level (in the same directory that the InnovatorServerConfig.xml is located). I just confirmed it on my own machine as well.

    I would also double check the parameters you are setting pre install with the documentation provided with the CD image (specifically the "Aras Innovator 12.0 - Upgrading to Service Pack 9 from Aras Innovator 12.0.pdf") to confirm you're giving it the correct URL, database, and install path (pointing to the root or top level as I just mentioned)

    Best,

    Nithin

  • Hi Nithin

    I made double sure of the above, but still get the same error message.

    I've attached the details I filled in. Additionally, I tried http://localhost/InnovatorServer/OAuthServer which returned a 404 error.