Error: Cannot access OAuth Server due to 502 (Bad Gateway)

I'm attempting to install Aras 12 on a Windows 10 machine, following this guide:

After a bunch of attempts, I'm pretty sure I have all of the right things installed:

  • .NET Framework 4.7.2
  • ASP.NET Core/.NET Core 2.1.8
  • Microsoft Visual C++ 2015 Redistributable
  • IIS is turned on and all the correct features are activated
  • SQL Server 2014

Aras installs without any issues, but when I try to connect to localhost/InnovatorServer, I get "Error: Cannot access OAuth Server due to 502 (Bad Gateway)"

Going to Windows Event Viewer for more details, I get: 

Application 'MACHINE/WEBROOT/APPHOST/DEFAULT WEB SITE/INNOVATORSERVER/OAUTHSERVER' with physical root 'C:\Program Files (x86)\Aras\Innovator\OAuthServer\' failed to start process with commandline 'dotnet .\Bin\Aras.OAuth.Server.dll', ErrorCode = '0x80004005 : 80008083.

Googling tells me that those error codes mean:

  • 0x80004005 – file is missing or cannot be accessed,
  • 0x80008083 – code for version conflict.

I have confirmed that the dll is in the OAuthServer\Bin file.

I have tried uninstalling and reinstalling everything, restarting the computer between each step. I tried doing a system restore and then reinstalling everything. No matter what, I keep getting this same error, and am not really sure how to proceed.

Any advice would be greatly appreciated.

  • Hi Jonfurniss,

    A 502 can be tricky since it could be caused by a variety of things. Have you taken a look at this post on the community forum, seems like someone else has run into this issue as well. Another installation guide you can confirm with is this one

    One other possibility could be maybe one of the  application pools isn't started in IIS and that's why the OAuth server is not being accessed. You can check this by opening IIS and clicking on Application Pools on the left sidebar, then checking if the Aras OAuth AppPool ASP.NET Core is started. If you select that Application Pool you can confirm that the instance was installed/setup here as well by clicking "view applications" on the right sidebar. 

    Hope this helps!



  • Another very basic issue could be a syntax or other error in your "OAuth.config" file.

    This is the first and easiest thing to check.

    Kind Regards


  • In my case it was always the missing C++ redistributable. I actually made a complete video about HTTP Error codes that can appear during an Innovator installation :) :

  • I can fixed this issue by use dotnet command to check what is error from command

    use windows powershell  and run this command

     dotnet "C:\Program Files (x86)\aras\Innovator\OAuthServer\bin\Aras.OAuth.Server.dll"

    in may case it reply

    You must install or update .NET to run this application.

    App: C:\Program Files (x86)\aras\Innovator\OAuthServer\bin\Aras.OAuth.Server.dll
    Architecture: x64
    Framework: 'Microsoft.NETCore.App', version '2.1.30' (x64)
    .NET location: C:\Program Files\dotnet\

    The following frameworks were found:
    2.1.8 at [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    5.0.17 at [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]
    6.0.9 at [C:\Program Files\dotnet\shared\Microsoft.NETCore.App]

    Learn about framework resolution:

    To install missing framework, download:

    then you need to install the missing  framework.