Workflow(?) Error - Conversion from type 'DBNull' to 'String' is not valid.

Good day all.  I created a New Document Request (NDR) for our system.  We are trying to test it out now.  I can start the process, but the next person in line gets the Conversion from type 'DBNull' to 'String' is not valid error.  There are four options for him to vote on; Assign Drafter - A, Assign Drafter - B, Reject, and Cancel.  All options, except for Cancel, cause the error.  I cannot figure out where this is coming from.  I didn't have any problems when I ran this as an admin.  I mirrored this request to our ECO process. 

I've checked the Lifecycle Map to make sure all paths have a role assigned.

I looked at the Workflow Process and can't understand why this is happening. 

This shouldn't be caused by the notifications, they work fine when I start the process. 

Any suggestions would be grateful.  Thank you.

  • It looks like the problem I had was with the Notification that was assigned to the Activity on the workflow.  Once I removed the notification, everything worked fine.  I believe the notification was trying to pull information about the NDR that was not there, or I told it to pull information that was not there.  I have since redone the notification & everything is working fine now.   Thanks.