Issue in ARAS Innovator 12 localhost - very slow

Hello,

I have installed ARAS Innovator 12 in my laptop which is windows 10. After successful login, TOC page takes more than 30mins to load. Tried in all browsers but facing same issue.

Tried couple of browser settings but none of them are working. Just to create an itemtype it would probably take 15mins. Could you pls suggest some solution for localhost speed up.

Thanks

Parents
  • EDIT: 2 hours later and I'm removing this as a suggested answer. I'm now having huge problems. I need to hit login extra times while waiting several minutes. This is not the solution as the behavior has severely deteriorated.

    ....  
    I [thought I] found a solution that works for me. Intial load time, from auth screen to main gui, on cleared cache with just started IIS is drastically improved from 2 minutes to ~30 seconds.
    On Win10 I hit the Windblows button, typed "IIS" and opened IIS Management. In my reading there were various settings - and even in the hints on the windows there's misinformation to match this old info on the webz. So, the one thing I did change is:

    Right click on Default Site. Goto: Manage Website > Advanced Settings. Find "Preload Enabled" and set it to True.

    Now, open the Default Site tree and find your Innovator site. Repeat the steps for Default Site, ultimately enabling "Preload Enabled".

    Restart IIS and give it a try! Login came up in 2.6secs. From login to main took a lot longer than that, but a lot less than normal!

    NOTE: There's also settings for limits that are on multiple older write-ups around improving IIS performance. They suggest, as the hint text still does, that setting limits with "-1" or "0" is to turn off the limit altogether. I cannot change any to either of those values though. 

    NEXT: I want to see if I can ramp up the speed for responses from the locally running Db! I'll follow up if I manage that and it makes things even faster.

Reply
  • EDIT: 2 hours later and I'm removing this as a suggested answer. I'm now having huge problems. I need to hit login extra times while waiting several minutes. This is not the solution as the behavior has severely deteriorated.

    ....  
    I [thought I] found a solution that works for me. Intial load time, from auth screen to main gui, on cleared cache with just started IIS is drastically improved from 2 minutes to ~30 seconds.
    On Win10 I hit the Windblows button, typed "IIS" and opened IIS Management. In my reading there were various settings - and even in the hints on the windows there's misinformation to match this old info on the webz. So, the one thing I did change is:

    Right click on Default Site. Goto: Manage Website > Advanced Settings. Find "Preload Enabled" and set it to True.

    Now, open the Default Site tree and find your Innovator site. Repeat the steps for Default Site, ultimately enabling "Preload Enabled".

    Restart IIS and give it a try! Login came up in 2.6secs. From login to main took a lot longer than that, but a lot less than normal!

    NOTE: There's also settings for limits that are on multiple older write-ups around improving IIS performance. They suggest, as the hint text still does, that setting limits with "-1" or "0" is to turn off the limit altogether. I cannot change any to either of those values though. 

    NEXT: I want to see if I can ramp up the speed for responses from the locally running Db! I'll follow up if I manage that and it makes things even faster.

Children
No Data