Cannot upload files to the Vault Server

I have my instance of Aras Innovator running on an Azure Windows Server 2016 VM, and have it exposed to the Internet, allowing myself and others involved in development / testing of our configuration to easily connect from wherever they are. Everything is working great it seems, except for trying to upload files, for example a custom icon or a Document. I get two different error messages when I try to upload a file, I was going to attach screen grabs of the errors, but can't see any way to attach image. So here is their text, verbatim: 1st: "An internal error has occured." 1st (after click "Show Details"): "Technical Message: false Cannot upload file. Exception name: "WebException"; Exception message: "The remote server returned an error: 500 Stack Trace: Client Side Error" 2nd: "Failed to upload the files. Is the specified Vault Server URL: "">www.mydomain.com/.../vaultserver.aspx" correct ?" I thought maybe this was something to do with permissions in the Vault Server directory for something like the IUSR account, but I have tried changing permissions such as that and still have had the same issue. Perhaps it is a permissions thing and I am just not looking into the right specifics. Thanks in advance!
Parents
  • Hi cnccarthy,

    I know this threat is 2 years old, but I wonder if you were able to find a solution or if anyone else faced the same? We have a test environement that worked well so far. We wanted to share it with additional users and hosted the platform online. But since this the up- and download of files is not possible anymore and I receive the same error messages.

  • I have the same issue for an on premise instance running with the file vault directory local to the application server. Currently working with an Aras support agent to resolve this. I think my vault server url is wrong, but just can't figure out what to change it into

Reply
  • I have the same issue for an on premise instance running with the file vault directory local to the application server. Currently working with an Aras support agent to resolve this. I think my vault server url is wrong, but just can't figure out what to change it into

Children
  • Hi,

    turned out that a wrong server time caused the issue. The server time was slightly ahead. This was never a problem while working directly on the test server, but turned into one as soon we changed settings for hosting. So in my case the Oauth tokens were assigned - but only valid in the near future. An unnecessary issue. I noticed the wrong time several times, but as there wasn´t any data in the database I simply ignored it.

    In addition, I had to use the standard relative Vault Url Pattern to make the Vault work on all domains: $[HTTP_PREFIX_SERVER]$[HTTP_HOST_SERVER]$[HTTP_PORT_SERVER]$[HTTP_PATH_SERVER]/vault/vaultserver.aspx