When exposing the affected items tab on express eco I get TypeError: Cannot create property 'width' on string 'image'

Any ideas on how to resolve this? It doesn't seem to affect anything other than UI response after it appears but it is quite an annoyance to anyone that clicks on the tab. I am trying to display some properties for review.

  • Hi,

    I have seen this bug too in various scenarios. It depends a little bit on your Innovator version and the planet rotation of the universe (=the error message sometimes appears for no reason). 

    In the Affected Items tab you have one column that should display an item icon. Do you see the icon? I am pretty sure this property is the source of this error message. In my case hide/unhide the property fixed the error....(yes, I wished I would know a better solution)

  • Thanks for the reply. I think it is happening for no reason unfortunately as I have tried hiding and re-enabling all the available columns I want displayed and the error presents no matter what. I wonder if this is a unique situation as I am using an affected item relationship elsewhere and do not see this same issue. I will have to dig deeper as the only place I can see potential issue is the relationship item itself.

  • You can check what happens when you disable the Method 'PE_PopulateAffectedType'. This one populated the image.

Reply Children
  • Thanks for the tip, it produced the same result.

  • I wished I would know the root-case for this one, but right now I only know solutions based on Voodoo and karma.

    I remember in one case the error message was related to a foreign property where I linked a thumbnail. I removed the property completely and then added it again --> problem solved.

    In another case I had to re-add poly-sources in a PolyItem type.

    The bug first appeared in Innovator 12SP18 in my case. Never have seen it in previous versions.

  • Ah thanks for this. I will give this a try. I have added some foreign properties and a few months ago we also updated to SP18.

  • I checked my database and have seen that I reported this one to Aras last year.

    They even sent me a solution (codetree patch), but it only partly fixed the issue. I ended up getting different error messages. But I think in the mean time Aras may have found a better solution:

    When you want to ask by yourself, you could refer to:

     SI-031239 - Upgrade 12SP17 - ECO - TypeError: Cannot create property 'editable' on string 'image'

    Would be happy to know, if you can get the latest solution for this one! 


    Of topic:

    If you use 12SP18 and want to support one of my own tasks:

    Tell Aras that you 100% support this request and urgently need a patch:

     SI-031505 - Item edit issue when previous version is opened is opened same time

    Thanks :-)