Batch Loader Utility: Automatically add extra characters if a cell contains double quotation mark

I'm using Batch Loader to import data into ARAS from a csv file. I notice that if a cell contains a double quotation mark ", the tool will automatically add some extra " to the content. It is an annoying behavior.

Example: A cell content in the CSV file is: This is test" field .

=> What is display in Batch Loader: "This is test"" field."

Does anyone know how to fix the problem? Thanks in advance.

Parents
  • Jacky Phan,

    I'm having a bit of trouble replicating your issue. The batchloader combines the data row with the AML template, so you should be able to see the AML that's going to be run by clicking on a row. Do you see your extra quotation marks there? They may well be escaped in some fashion, since double quotes are reserved characters in XML. Look for " where you might expect a double quote.

    I know that some spreadsheet editors have an annoying habit of adding quotes around cells which contain a string. I use Open Office Calc a lot, and I have to manually uncheck the checkbox to add the surrounding quote every time I save a file for batch loading. If you open the file with Notepad or some equivalent do you still see the extra quotes?

    If you're not seeing the extra quotes in your file, but do see them in the loaded data in Innovator, let me know what they look like in the Template preview.

    Skyler C.

  • Skyler C.

    You mentioned the correct point, it is because of spreadsheet editors that automatically surrounds double quotes by this rule: "Fields with embedded commas or double-quote characters must be quoted" which described in https://en.wikipedia.org/wiki/Comma-separated_values#Basic_rules.

    I tried to use Open Office Calc tool to open an EXCEL file, then save it as CSV without Text Delimiter. It worked as expected.

    Thank you very much!

  • Jacky, 

    You're welcome, glad to help! Most of my work with the batchloader has been in text editors, so I'm used to spotting errant quotations. Prior to remembering Open Offic Calc could save without the delimiter, I had a regular expression doing the job. Calc is much easier!

    Skyler

Reply
  • Jacky, 

    You're welcome, glad to help! Most of my work with the batchloader has been in text editors, so I'm used to spotting errant quotations. Prior to remembering Open Offic Calc could save without the delimiter, I had a regular expression doing the job. Calc is much easier!

    Skyler

Children
No Data