Agent with given Windows Service name exists

I'm trying to overcome this error:

I had tried to install v12 and while it seemed to complete my db logins weren't working, so I did an uninstall, I cleared out the db and the users. I restarted the VM.

Now, installing, I put the same name for the Agent Agent that I had on the erroneous installation (where I did get a error popup, but it went away and continued configuring the db - MSSQL Express, localhost). But, it doesn't like that. Seems the service name isn't cleaned out on uninstall.

I've tried some "sc query" commands and can't find the service using query by name, I can't delete the service "sc delete ArasInnovatorAgent12" (not found), and I'm not just going to accept it this time. I've seen this, but I'm of the mind that when a full uninstall is performed it should xney the service too! But, where is it? I've restarted the VM multiple times.
I just ran: msiexec /regserver, restarted again, to no avail. Meh.

I just found this... let's see! HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\ArasInnovatorAgent_ArasInnovatorAgent12