Error: Method "CE_LinkManufacturer" failed

Hello, Dear

<Version 12.0 Build 13341>

Regarding add maker information, cannot add data of "CE Manufacturer name "

Detected Error:  Method "CE_LinkManufacturer" failed.

technical message aras_object "undefined ": "Not a single item

I suspect SQL database table have something issue.

And I cannot find table  for CE_LinkManufacturer.

Though I imported Aras component Engineering "12.0R1", No failure was occurred at that time.

Would you please let me know any suggestion?

Sincerely

Parents
  • Hi,

    sorry I somehow lost track of this thread. What do you currently try to achieve? Where you able to link your Manufacturer? Maybe you could provide some steps to reproduce.
    You shouldn´t need to customize the CE_LinkManufacturer Method. Do you have already asked Aras support about this issue?

    Be really careful about any changes you do in CE! The CE code is insufficiently secured and mistakes can happen too easy. Unfortunately, Aras did not spend any energy so far to make the code more fail save. Be careful not to end up as a scapegoat for their development fails!

  • Hi ,

    Thank you for your advice.

    fortunately I've just checked  CE_LinkManufacturer Method only, I don't change any parameter.

    Regarding the manufacturer record, I cannot add  Manufacturer name in other menu.

    And Manufacturer name looks link to the cloud Manufacturer... ?

    But I'm not sure I cannot access Cloud Manufacturer from sourcing menu.

    Anyway, error dialog is indicated client side error.

    It's very curious I can find unknown CE manufacturer name from inquiry dialog.

    But that manufacturer name is invalid data . because I could not add it before.

    I don't know why invalid data is existed in the inquiry.

    I'm thinking whether should re-install aras innovator and SQL server.

    Best Regards!

  • Hi, 

    have you looked at the  'Linking Manufacturers' chapter in the CE User Guide?

    Just to be sure:
    - Are you able to add regular Manufacturer items at all? E.g. when you create a new Manufacturer and add the name by your self, can you save this item?

    - Can you do a regular search for CE Parts in Cloud Manufacturer Parts? If this one already makes trouble, you may have some general connection problem with CE. 

    I really recommend you to write an email to Aras support. They are quite good in CE troubleshooting!

  • Hi ,

    I overlooked some point in the CE user guide.

    My new findings from your advice as below:

    I had read the CE user guide chapter 3 (Open Edition (Level 1) user guide.

    1.For our system, we cannot open Cloud Manufacturer Part Search.

    →Exactly, I cannot see search box as user CE user guide Figure 38.

    So  We "may have some general connection problem with CE"

    2.I tried to add part by "Manufacture Parts".

    →I can save  the parts information except "Manufacturer name".

     

    3.Tried to modify  Manufacturer Part

    Detected error as below

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="">schemas.xmlsoap.org/.../"><SOAP-ENV:Body><SOAP-ENV:Fault xmlns:af="">www.aras.com/.../faultcode><faultstring><![CDATA[Line number 56, Error Number: CS0234, The type or namespace name 'CE' does not exist in the namespace 'Aras' (are you missing an assembly reference?)
    ]]></faultstring><detail><af:legacy_detail><![CDATA[Line number 56, Error Number: CS0234, The type or namespace name 'CE' does not exist in the namespace 'Aras' (are you missing an assembly reference?)
    ]]></af:legacy_detail><af:exception message="Line number 56, Error Number: CS0234, The type or namespace name 'CE' does not exist in the namespace 'Aras' (are you missing an assembly reference?)&#13;&#10;" type="System.ApplicationException"/></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

    As you recommend, I'll try to understand ARAS innovator well and ask ARAS support this case.

    Best Regards!

Reply
  • Hi ,

    I overlooked some point in the CE user guide.

    My new findings from your advice as below:

    I had read the CE user guide chapter 3 (Open Edition (Level 1) user guide.

    1.For our system, we cannot open Cloud Manufacturer Part Search.

    →Exactly, I cannot see search box as user CE user guide Figure 38.

    So  We "may have some general connection problem with CE"

    2.I tried to add part by "Manufacture Parts".

    →I can save  the parts information except "Manufacturer name".

     

    3.Tried to modify  Manufacturer Part

    Detected error as below

    <SOAP-ENV:Envelope xmlns:SOAP-ENV="">schemas.xmlsoap.org/.../"><SOAP-ENV:Body><SOAP-ENV:Fault xmlns:af="">www.aras.com/.../faultcode><faultstring><![CDATA[Line number 56, Error Number: CS0234, The type or namespace name 'CE' does not exist in the namespace 'Aras' (are you missing an assembly reference?)
    ]]></faultstring><detail><af:legacy_detail><![CDATA[Line number 56, Error Number: CS0234, The type or namespace name 'CE' does not exist in the namespace 'Aras' (are you missing an assembly reference?)
    ]]></af:legacy_detail><af:exception message="Line number 56, Error Number: CS0234, The type or namespace name 'CE' does not exist in the namespace 'Aras' (are you missing an assembly reference?)&#13;&#10;" type="System.ApplicationException"/></detail></SOAP-ENV:Fault></SOAP-ENV:Body></SOAP-ENV:Envelope>

    As you recommend, I'll try to understand ARAS innovator well and ask ARAS support this case.

    Best Regards!

Children
No Data