Aras 12: Error: Cannot access OAuth Server due to 500 (Internal Server Error)

Hi,

We are getting an error as "Error: Cannot access OAuth Server due to 500 (Internal Server Error)" while accessing Aras12. Please help me how to resolve this error.I'm attaching screenshot for your reference. 

Thanks

Sunil

Parents Reply Children
  • I needed to update .Net Framework 4.7.2 ASP.Net Core/.NET Core Runtime and Hosting Bundle on our server.  Hope that helps.  

  • Hello,

    I just saw this issue on another machine that also already had the runtime and hosting bundle. The issue with that machine was that it was brand new and a recent Windows update that had .NET 4.8 installed but not .NET 4.7.2. I was able to resolve this issue by installing the .NET 4.7.2 developer pack

    Could you check if .NET 4.7.2 is installed on the server you're having trouble with? One thing to note is that if .NET 4.8 is already installed, you won't be able to use the Runtime installer from the link above since it will complain that a newer version is already installed. That's why I had to use the developer pack instead.

    Chris

  • I installed 12SP4 for the first time and running to the same issue. I have installed dotnet-sdk-2.1.804-win-x64 and NDP472-DevPack-ENU and still can't get past the issue. Is there a solution posted anywhere?

  • Hi Sgopinath,

    Sometimes it is the framework license. Send a request for a new license, but this time use your Wireless LAN adapter Wifi MAC address. This is assuming that you have the right .Net Framework/.Net Core Runtime and Hosting. You can change the license in your InnovatorServerConfig in the root directory then reset IIS. 

    Best,

    Nithin

  • Hello Chris,

    I have the same issue. I have new machine with Windows 10 Pro version 1909, which has .Net Framework 4.8 Advanced Services. And hence I am ending up in getting error 500.

    As you have correctly pointed out .Net 4.7.2 runtime cant be installed as I already have 4.8. I have installed developers pack for .Net 4.7.2. Do I need to change any configuration file entry so that ARAS application points to .Net 4.7.2?

    I am still getting the same error 500.

    Any help wold be highly appreciated.

    Thanks,

    Jayraj

  • Although this is weird, the issue was resolved once I installed Hosting Bundle with version 2.1.11 instead of 2.1.8

    Here is useful info might save some time for somebody

    OS: Windows 10 Pro Version 1909
    Windows Feature .Net Framework: 4.8 with Advances Services

    The issue was resolved once I installed hosting bundle version 2.1.11 instead of 2.1.8

    Although it is contradicting ARAS documentation regarding hosting bundle version but it worked for me.

    Thanks,

    Jayraj

  • Well... I was spending two weeks just to fix similar error. Luckily I found your post. Installing Hosting Bundle 2.1.11 helped me to resolve the issue,

    Again, Thanks a lot...!

  • I also face the same issue. This post helped me to resolve.


    Thanks you Jayraj

  • Yes, after open support since November 11th, 2020, 5 hours of live calls, tons of IT change requests to get the garbage cleaned up between failed installs, proving dependencies were installed, and in the right order, and an 8 hour meeting with IT today, installing 4.7.2 Dev Pack and the latest Hosting Bundle got us a running Aras. I mean I can't stand to look at it, but it is running. I can finally work again. What garbage.