Aras 12: Error: Cannot access OAuth Server due to 500 (Internal Server Error)

Hi,

We are getting an error as "Error: Cannot access OAuth Server due to 500 (Internal Server Error)" while accessing Aras12. Please help me how to resolve this error.I'm attaching screenshot for your reference. 

Thanks

Sunil

  • Hi there,

    I see you posted on the other thread about this same issue, but I wanted to leave a comment here for people who find this in the future. Aras Innovator 12.0 has new requirements from Aras Innovator 11.0. Please check Section 2.1.2 of the 12.0 Installation Guide and ensure you have all of the pre-requisite applications installed. 

    This particular issue seems to be most commonly associated with missing the ASP.NET Core/.NET Core Runtime and Hosting Bundle version 2.1.8.

    Chris

    Christopher Gillis

    Aras Labs Software Engineer

  • aras does a poor job of informing users that server requirements have changed.  I appreciate your diligence in responding to these messages, especially as gently as you do which is appreciated.  Nothing is more embarrassing than NOT reading the directions then asking for help only to be told to READ the directions.  

    My case was an upgrade and during an upgrade a user typically assumes the requirements have been previously met, furthermore, most software companies include the installation of necessary software.  

    Ill accept my portion of the blame for not reading, aras needs to do a better job of informing its users that requirements have changed, i mean you could have merely highlighted the section with a little note that said *ATTENTION*, instead aras chose to retroactively answer each question related to that specific issue on the community board.

    New aras looks good.

  • I personally think Aras does great job documenting!! (one has to read it)

    Yet I seem to have this specific component installed and getting the same error. Any other suggestion what may be the problem?

  • I needed to update .Net Framework 4.7.2 ASP.Net Core/.NET Core Runtime and Hosting Bundle on our server.  Hope that helps.  

  • Hello,

    I just saw this issue on another machine that also already had the runtime and hosting bundle. The issue with that machine was that it was brand new and a recent Windows update that had .NET 4.8 installed but not .NET 4.7.2. I was able to resolve this issue by installing the .NET 4.7.2 developer pack

    Could you check if .NET 4.7.2 is installed on the server you're having trouble with? One thing to note is that if .NET 4.8 is already installed, you won't be able to use the Runtime installer from the link above since it will complain that a newer version is already installed. That's why I had to use the developer pack instead.

    Chris

  • I installed 12SP4 for the first time and running to the same issue. I have installed dotnet-sdk-2.1.804-win-x64 and NDP472-DevPack-ENU and still can't get past the issue. Is there a solution posted anywhere?

  • Hi Sgopinath,

    Sometimes it is the framework license. Send a request for a new license, but this time use your Wireless LAN adapter Wifi MAC address. This is assuming that you have the right .Net Framework/.Net Core Runtime and Hosting. You can change the license in your InnovatorServerConfig in the root directory then reset IIS. 

    Best,

    Nithin

  • Hello SunilReddy,

    I had this Error 500 before but my scenario might be different. I lost for a while due to the error message (Internal Server Error). My issue is due to missing files in the Valve folder. I'm not sure if it is applicable to your case or not. I would suggest to see where the OAuth would be located in PLM Database Tables or Valve folder.

    Jakk 

  • Hello Chris,

    I have the same issue. I have new machine with Windows 10 Pro version 1909, which has .Net Framework 4.8 Advanced Services. And hence I am ending up in getting error 500.

    As you have correctly pointed out .Net 4.7.2 runtime cant be installed as I already have 4.8. I have installed developers pack for .Net 4.7.2. Do I need to change any configuration file entry so that ARAS application points to .Net 4.7.2?

    I am still getting the same error 500.

    Any help wold be highly appreciated.

    Thanks,

    Jayraj

  • Although this is weird, the issue was resolved once I installed Hosting Bundle with version 2.1.11 instead of 2.1.8

    Here is useful info might save some time for somebody

    OS: Windows 10 Pro Version 1909
    Windows Feature .Net Framework: 4.8 with Advances Services

    The issue was resolved once I installed hosting bundle version 2.1.11 instead of 2.1.8

    Although it is contradicting ARAS documentation regarding hosting bundle version but it worked for me.

    Thanks,

    Jayraj