Application is not Exist in Innovator

Im trying to get some of the modules (if that is the right term) installed using the Aras updater.

I go through the wizard, download, then choose to install. Enter the URL/Credentials/DBname, then i get an error.

What am i doing wrong? 

Im thinking it may be something as simple as i dont have the right license? Or i have not setup the solutions module properly?

Thanks.

Parents
  • Anyone have any suggestions? Any at all?

  • Can you confirm the innovator URL you are trying to use ? Also is the application accessible in browser ? Try using the URL without /client

    http://localhost/InnovatorServer/

  • if i go to /innovatorserver it adds /client for me. but i have been using the public url i think, let me try localhost.

  • 2021-02-02 12:32:21,479 [10] INFO Aras.Tools.ArasUpdateGui.Logger Checking package started: 'C:\ProgramData\Aras\ArasUpdate\TD\12.0.1139\package.config'
    2021-02-02 12:32:21,514 [10] INFO Aras.Tools.ArasUpdateGui.Logger Checking package finished
    2021-02-02 12:32:21,524 [10] INFO Aras.Tools.ArasUpdateGui.Logger Installation of the package started : 'TD' from 'C:\ProgramData\Aras\ArasUpdate\TD\12.0.1139' directory
    2021-02-02 12:32:21,525 [10] INFO Aras.Tools.ArasUpdateGui.Logger CompatibilityPackage started
    2021-02-02 12:32:21,547 [10] INFO Aras.Tools.ArasUpdateGui.Logger Checking module 'DB' compatibility.
    2021-02-02 12:32:21,548 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application started
    2021-02-02 12:32:21,723 [10] INFO Aras.Tools.ArasUpdateGui.Logger Variable 'VersionServiceUpdate' is found in DB.The value : '0'.
    2021-02-02 12:32:21,724 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application finished
    2021-02-02 12:32:21,725 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application started
    2021-02-02 12:32:21,859 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Variable 'Technical Documentation' should not exist in the DB.}
    2021-02-02 12:32:21,860 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application finished
    2021-02-02 12:32:21,870 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application started
    2021-02-02 12:32:22,017 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Application is not exist in Innovator (com.aras.innovator.solution.PLM).}
    2021-02-02 12:32:22,019 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application finished
    2021-02-02 12:32:22,030 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application started
    2021-02-02 12:32:22,187 [10] INFO Aras.Tools.ArasUpdateGui.Logger The innovator DB contains AML package with name : 'com.aras.innovator.tdf'.
    2021-02-02 12:32:22,188 [10] INFO Aras.Tools.ArasUpdateGui.Logger Application finished
    2021-02-02 12:32:22,200 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:22,201 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 None'.
    2021-02-02 12:32:22,404 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:22,406 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:22,416 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:22,418 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP1'.
    2021-02-02 12:32:22,531 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:22,532 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:22,543 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:22,544 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP2'.
    2021-02-02 12:32:22,660 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:22,661 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:22,673 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:22,674 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP3'.
    2021-02-02 12:32:22,795 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:22,796 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:22,810 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:22,811 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP4'.
    2021-02-02 12:32:22,932 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:22,933 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:22,944 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:22,945 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP5'.
    2021-02-02 12:32:23,078 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:23,079 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:23,090 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:23,091 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP6'.
    2021-02-02 12:32:23,219 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:23,220 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:23,230 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:23,231 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP7'.
    2021-02-02 12:32:23,362 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:23,363 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:23,374 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:23,375 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP8'.
    2021-02-02 12:32:23,506 [10] WARN Aras.Tools.ArasUpdateGui.Logger String[] {Incompatible version of Innovator}
    2021-02-02 12:32:23,507 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:23,518 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence started
    2021-02-02 12:32:23,519 [10] INFO Aras.Tools.ArasUpdateGui.Logger Required version of Innovator : '12.0 SP9'.
    2021-02-02 12:32:23,650 [10] INFO Aras.Tools.ArasUpdateGui.Logger InnovatorDependence finished
    2021-02-02 12:32:23,654 [10] WARN Aras.Tools.ArasUpdateGui.Logger Variable 'Technical Documentation' should not exist in the DB.
    Application is not exist in Innovator (com.aras.innovator.solution.PLM).
    2021-02-02 12:32:23,660 [10] INFO Aras.Tools.ArasUpdateGui.Logger CompatibilityPackage finished
    2021-02-02 12:32:23,664 [10] ERROR Aras.Tools.ArasUpdateGui.Logger Aras.Tools.ArasUpdateCore.Implementations.Commands.CheckCompatibilityPackageCommand: Variable 'Technical Documentation' should not exist in the DB.
    Application is not exist in Innovator (com.aras.innovator.solution.PLM).
    2021-02-02 12:32:23,666 [10] INFO Aras.Tools.ArasUpdateGui.Logger Operation 'Install' failed

  • if i try the manual import tool i get this error, 

  • From the error, I guess variable Technical Documentation already exist in ARAS instance. Navigate to Administrators --> Variable --> Search for Technical Documentation and delete. Try import after deleting this variable

  • Thanks, Some progress i think.

    I now get this error, but the variable in Aras now has a version number!

  • Can you check anything related to Technical Documentation (Form, Identity, Item Type, Permission, Method.. etc) is already imported in your instance. If yes, Can you try deleting that and import. Also Can you confirm while importing you are using merge option 

  • Definitely using the merge option. Am i looking in the database or inside Aras itself?

Reply Children
  • Ok, i decided to start over as this was a fresh test install.

    It appears to be an issue caused by disabling TLS 1.0 on the server.

    In fact the software wont even install with TLS 1.0 disabled, same issue seen here. https://community.aras.com/f/getting-started/35925/error-microsoft-odbc-sql-server-driver-ssl-security-error

    I have setup the software again from scratch with SQL Express 17, leaving TLS 1.0 enabled and i was able to install the TD module. I disabled TLS1.0 and was then not able to install a different module. I am just enabling it again now and going to test the install again.

  • I have successfully installed, Requirements Engineering and Technical Documentation (with TLS 1.0 enabled) i have been unsuccessful with QMS, error log:

    2021-02-04 14:16:43,171 [11] WARN Aras.Tools.ArasUpdateGui.Logger Variable 'Office Connector' is not found in DB.
    Variable 'Office Connector' is not found in DB.
    2021-02-04 14:16:43,172 [11] INFO Aras.Tools.ArasUpdateGui.Logger CompatibilityPackage finished
    2021-02-04 14:16:43,173 [11] ERROR Aras.Tools.ArasUpdateGui.Logger Aras.Tools.ArasUpdateCore.Implementations.Commands.CheckCompatibilityPackageCommand: Variable 'Office Connector' is not found in DB.
    Variable 'Office Connector' is not found in DB.
    2021-02-04 14:16:43,174 [11] INFO Aras.Tools.ArasUpdateGui.Logger Operation 'Install' failed

  • Resolved that -by choosing not to install the office connector.

    Most other modules have now installed correctly.

    Is there any guidance on how to successfully disable TLS1.0 with Aras?