Howto upgrade Enterprise Search?


on my Innovator 12.0 SP9 testserver i've managed to install and configure Enterprise Search 12.0 SP9, so far so good, works like a charm.

Now i need to to upgrade to 12.0 SP10.

Innovator upgrade process of SP9 to SP10 did work as expected, but afterwards none of the Enterprise Search services run anymore,

when started, they immediately shutdown, output in the service.log:

Info       A.E.A.AgentService.Initialization: Service has been initialized.
Error     A.E.F.A.AppServiceBase.CheckProductVersionCompatibility: It's impossible to start the Enterprise Search version 12.0 SP9 on the Aras Innovator version 12.0 SP10.
Log       A.E.F.A.AppServiceBase.StopService: Service stopped.

Has anyone an idea how to get Enterprise Search working again after an upgrade from SPx to SPy?

What's the easiest procedure to achieve this?

Best Regards


  • Hi Wolf, 

    ES is comprised of 3 main components (Index, Agent, and File Processor). Generally since ES is specific to an Aras Innovator instance you can only have one index setup to one instance at a time. Normally when installing a new instance you would need to uninstall all three components and reinstall them with the Index pointing to the new instance's server and database. 

    I am not entirely sure how this works with upgrades since the server and database names should remain the same, but the ES components you have installed are most likely only compatible with SP9. 

    My suggestion is to do this; uninstall those three components (from you program list) and make sure to use the SP10 ES installers within your SP10 CD image as follows: ArasESIndexSetup.msi, ArasESAgentSetup.msi, then ArasESFileProcessorSetup.msi. 

    Hope this helps!


  • Hello Nithin,

    it's not that much complicated!
    I've tested and found 2 ways to solve it, each ES service has its own service.config file, just adapt the four files and change the Servicepack tag and set it from SP9 to SP10, afterwards ES services can be started again and work as expected, without the need to upgrade.

    In case one would prefer to upgrade ES, here is how it worked for me:
    Prepared a new clean Innovator test instance with SP10 on a new VM, setup ES SP10, made a backup of ES program directory without *.config / *.log files.
    Replaced ES folder of my SP9 ES VM from that backup, changed the four service.config files Servicepack tags as described above, and then ES works again as exptected, now with upgraded ES codebase of SP10.

    I think Aras rebuilds all files in the codetree of ES newly with each servicepack, so that the files get new fileversion, SP9 had fileversion, and SP10 now has, but the main ES components didn't change, i.e. Solr is 6.4.1 in both SP9 and SP10.
    So i assume the codetree upgrade would be necessary only when major release would change, i.e. Innovator 11 to 12, but not with SP upgrades, or if explicitely documented.

    For me this issue is solved now.

    BR Wolf