MAKE SOME NOISE: community vs. /subscriber-portal - Logins are different and cannot set own password

Both the Subscriber Portal and these community pages are under the domain

Well, I was in class and I said I could never login to the subscriber portal. It was suggested that I use "Reset Password", so I did.

I thought it was broken because the spinner never stopped, but I did end up getting an email with a short scrambled password in it.

I was expecting to not be able to login here, to Community, with my old credentials. But, I can. And, if I go to the Subscriber Portal at: I need to go lookup the email and use that new password.

Well, I hope I can get some community voices supporting my problem as a must-fix! Having two logins for the same domain is silly.

It wouldn't be a problem if the login credentials worked for both and it appeared seamless. Even if there were two "buckets" at the very least I could then changed my Subscriber login password to one I can remember (and has more complexity than what is sent in a "reset" email)!

  • I support your request. Had the exact same problems in the past, but I was able to use the same password for both services. This fixed the issue for me and login to both services since then worked like a charm. 

    The subscriber portal is a connected to  Aras own internal Innovator instance. It might help to change your password in MyInnovator to improve the login to the subscriber portal page. But I am not 100% sure about this one.

    The community forum is a separate engine, but maybe when login in to community via the common address, the background service checks if you are partner, subscriber or free-user. They did a couple of modifications to the subscriber portal recently. Maybe this had some effects. I actually wait for Aras to finally provided the enhanced detailed road map in the subscriber portal. 

  • Support pointed to changing my password in the MyInnovator since I first posted this. That sounds like the solution - however, I can't log into MyInnovator *face palm*

    So, if you CAN login to MyInnovator and change your password that is a working solution according to support.
    And... Thank you for your support! :)