Blank Screen After login - Aras Innovator 12

Hi All,

New innovator setup implemented at our office version 12, i can login to clients without any issues but only having trouble with some machines like it goes to blank screen login.

1. I can see login page appears.

2. once login is performed, it goes to blank screen with windows 10 pro.

Tried with admin login as well.

Please help me to get the solution.



  • Open the browser debugger console first before starting Innovator. Normally the error message there are useful to find the issue.

    I actually had a similar issue. I still saw the login screen, but login itself failed. This one was caused by wrong timing on the server machine, so client tokens didn´t match the server time and simple were invalid for the server.

  • Amazing, I have struggled so much with this on different instances!

    How did you solve the timing issue?

  • Hi, in our case it was simply the Windows clock on the server. As the server was hosted outside our internal network, for mysterious reasons the clock was reset to a wrong time each day and than was two hours ahead. So users got very pretty and correct Oauth login tokens from Innovator -- valid in the future. As a workaround, I simply used a scheduled Windows task to correct the time each night until we finally was able to fix it (I don´t know what was wrong).

    But I think the blank screen behavior can be caused by many reasons. In my case there was hint regarding "timing" in the browser console that indicates my error.


  • Great, thanks for a swift reply and clarification. I have been pulling my hairs over this Slight smile

  • Excellent, even this solution worked for me ass well.

    Thank you very much 

  • This solution worked for me as well, which is fantastic. Drift Boss is an excellent drifting game that will keep you occupied for hours.

Reply Children
No Data