Innovator & Chrome

Hello -

I just installed Innovator 12sp4 on a new laptop.  I am able to login with IE and Firefox but with Chrome (which I would prefer to use) doesn't work.  After I enter username and password and submit the login form, the request is sent (I see the "waiting" message in the lower left of the window), then the screen is quickly repainted to the login page with the username and password fields empty.

I am using Chrome Version 84.0.4147.105 (Official Build) (64-bit).  I have disabled all extensions except Google apps.  And I did enter both localhost and local computer name in Chrome's pop-up "Allow" section.  I can't find any other suggestions on this forum on what else to attempt.

I would appreciate any recommendations for resolving this.  Thank you.

Michael

Parents Reply
  • Hello Nithin -

    Yes, I have liberally cleared cache during my testing.

    I tested 3 different Windows 10 PCs/laptops with the same version of Chrome against the installed Innovator server.  Only 1 of the 3 works; the other 2 behave as described.  Maybe it is OS related?

    Michael

Children
  • Hi Michael,

    Google Chrome implemented some cookie policies that can cause authentication can fail in some cases. This has been fixed in our more recent service packs, but you might still see this in 12.0 SP4.

    As a temporary solution, you can follow the two URLs below and set both of these cookie related flags to disabled.

    chrome://flags/#same-site-by-default-cookies
    chrome://flags/#cookies-without-same-site-must-be-secure

    Chris


    Christopher Gillis

    Aras Labs Software Engineer

  • Hello Christopher -

    That worked!  Thank you very much.

    This discussion can be closed.  But I will be flagging it for future reference.

    Michael

  • Hi Chris,

    We are also running 12.0 sp4 and had this issue before but was able to resolve it with the flags.  The issue seems to be back and I can't find these same flags in Chrome anymore (Version 91.0.4472.77). 

    Chrome and MS Edge both just clear the user and password fields when logging in with no error message when the password is correct. Internet Explorer let me log in just fine though. Also, when connecting to production I don't have any issues but I do when connecting to my local development instance. I was able to log in last week and didn't make any changes to the installation since then. Not sure what changed since then except a there was likely a Chrome update that got applied. 

    Any thoughts on what else I can try?

    -Ken

  • Hi Ken:

    Try this:-

    1. Edit the following file in the OAuth Server:
      1. OAuthServer\Bin\Aras.OAuth.Server.runtimeconfig.json
    2. Set the SuppressSameSiteNone value to “true”

    "configProperties": {
        "Microsoft.AspNetCore.SuppressSameSiteNone": true
    }

    3. Save the file. Then Restart your IIS once and please delete browser cache and now test it.

  • That worked great! Thank you shxing!