This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion


Philipp Reimer - Tuesday, October 25, 2016 10:19 AM:

Hello, im using Aras Innovator 11 SP05 on a Windows Server 2012R2 with a MSSQL 2014 Express Server. Whenever i start the Aras Innovator the Login Window doesnt show any selectable Database. And if i want to login i get an Error Message that Displays "Missing Database" This is my InnovatorServerConfig.xml file: I tried to reinstall the Aras Innovator multiple times but I always get the same Error. Maybe someone here can help me find a solution to my Problem. Thanks in advance

edonahue - Tuesday, October 25, 2016 4:50 PM:

Hi Phillip,

I'm not seeing your InnovatorServerConfig.xml file. Could you copy the contents from the file into a reply on this thread? In the meantime, here are some things you can check out that may be interfering with your login attempts:

  • Are the id and database attributes in the DB-Connection tag set to the same value?
  • Do you have any special characters in the id, database, or pwd attributes on the DB-Connection tag?
  • Is the SQL instance listed in the server attribute currently running?
  • If the Aras Innovator installation and the database are on two separate servers, can you ping the SQL server from the application server?

Philipp Reimer - Wednesday, October 26, 2016 2:06 AM:

Well it seems the format of my original post was changed but never mind.

So here is my InnovatorServerConfig.xml file:

<?xml version="1.0" encoding="UTF-8"?>
 <UI-Tailoring login_splash="../images/aras-innovator.svg" branding_img="../images/aras-innovator.svg" product_name="Aras Innovator" banner_url="../scripts/banner.aspx" banner_height="50"/>
 <IEClient RequiredSyncMode5="Automatically"/>
 <operating_parameter key="debug_log_flag" value="false"/>
 <operating_parameter key="debug_log_limit" value="10000"/>
 <operating_parameter key="debug_log_pretty" value="true"/>
 <disabled_operating_parameter key="performance_logging" value="cpu"/>
 <operating_parameter key="xslt_processor_debug" value="false"/>
 <disabled_operating_parameter key="email_debug_option" value="file"/>
 <License lic_type="Unlimited" lic_key="b02f0a4779fd4080a8539c94cc2b6a16" act_key="D6BADD92CE9E4D3A9B8A9F9D11209DB9" company=""/>
 <Mail SMTPServer="queue"/>
 <operating_parameter key="temp_folder" value="C:Program Files (x86)ArasInnovatorInnovatorServer emp"/>
 <operating_parameter key="ServerMethodTempDir" value="C:Program Files (x86)ArasInnovatorInnovatorServerdll"/>
 <operating_parameter key="debug_log_prefix" value="C:Program Files (x86)ArasInnovatorInnovatorServerlogs"/>
 <AgentService InnovatorToServiceAddress="localhost:8734/.../>
 <DB-Connection id="InnovatorSolutions" database="InnovatorSolutions" server="INARASPLM01SQLEXPRESS" uid="innovator" pwd="Root123!"/>
 <DB-Connection id="InnovatorSample" database="InnovatorSample" server="INARASPLM01SQLEXPRESS" uid="innovator" pwd="Root123!"/>


The SQL Server is runnning when i try to login and both installations are on the same MS 2012R2 Server.


edonahue - Wednesday, October 26, 2016 10:12 AM:

Hi Philipp,

Your InnovatorServerConfig.xml file looks good, so I'm thinking there may be a client configuration issue throwing a script error in the background. I recommend reviewing sections 1.1 and 1.2 in the Aras Innovator Client Setup Guide for the browser you are using.

You can also try another browser to see if the error is browser-specific. Aras 11.0 SP5 supports IE (9,10,11), Firefox 31 ESR, and Firefox 38 ESR.

Philipp Reimer - Wednesday, October 26, 2016 10:23 AM:

Hey Eli,

thanks again.

I tried another solution today... Because the whole installation was on a VM i was able to reset to the point where nothing was installed.

So I installed the MSSQL and the ISS Server again from scratch and the Aras Innovator as well.

I encountered the usual errors again but was able to fix them much quicker this time.

And somehow now everything works.

edonahue - Wednesday, October 26, 2016 10:27 AM:

Glad to hear it was resolved!