This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

DEVELOPERS FORUM - Unable to access Aras Innovator Administrator Component

shailendra - Thursday, July 7, 2016 4:24 AM:

I have installed Aras Innovator instance in my local machine. Till last date I was able to access every component of AI as I used to login with my Admin credentials.
Yesterday I was trying to import ItemType definition of another AI through Import Utility and it got failled due to error "duplicate Item Type already exist". Then I tried to delete some of duplicate ItemType from my AI instance. After deletion, I tried to login again and got know I have no more Admin rights in Innovator that I am not able to access Administrator component though I logged with Admin credentials. URL is  also showing "ArasRestrictedMode=1". 
Kindly let me know how to fix this problem as I want Administrator rights again.

edonahue - Thursday, July 7, 2016 12:11 PM:

Hi shailendra,

Do you know which ItemTypes you deleted from your instance? If you modified any Identities or Permissions or TOC Access items, you may have altered access for your admin user. If you'd like to access the Administration category in Innovator, another option is to login as the Super User (username: root; default pwd: innovator).

The ArasRestrictedMode flag is not related to user rights within Innovator, but the system rights allowed to the Innovator application. The ArasRestrictedMode flag indicates that the .NET security policy on the client has not been set and that you need to run the SDNS utility to set the policy. Running in ArasRestrictedMode does limit some user functionality, such as uploading files to the vault.


shailendra - Friday, July 8, 2016 12:59 AM:

Thanks for reply.

shailendra - Friday, July 8, 2016 2:49 AM:

Hi Eli,

 Yes I had delete some ItemType which was created by me.The name of the ItemType which  are deleted i.e  LogicalBlock, oslc_property_mapping like this.Also I didn't change or modification in any Identities or Permissions or TOC Access item.

Also I checking with super User login. Given same problem to administrator Component access.Let me know if any further solution.


edonahue - Friday, July 15, 2016 2:26 PM:

Hi shailendra,

Based on this information, I'm not able to diagnose the cause of this behavior without seeing the database. I recommend exporting your customizations and importing them into a clean database. I expect that this will resolve the issue.