This discussion has been locked.
You can no longer post new replies to this discussion. If you have a question you can start a new discussion

SUPPORT Q&A - Exception during Initialization

jiteshpanchal - Tuesday, May 27, 2008 10:51 AM:

Hello, I have just installed Aras Innovator 3.0.0 Build 5423.

When I try to login to Aras Innovator, I receive the following message:


Exception during initialization (InnovatorDatabaseException: Invalid object name 'ITEMTYPE'. in SQL: SELECT id FROM ITEMTYPE WHERE name = 'Locale')

I would be extremely grateful if anyone can help me with this problem.



Bill - Monday, June 2, 2008 11:16 PM:

I haven't seen this error before, but I will recommend that you go to and download a new copy of the installer.

If installing a new version doesn't fix the problem, please let me know what version of SQL server you are using, what OS you are using for client and server, and what language/region your clint OS is set for.


mgalvan801 - Tuesday, May 22, 2012 4:19 PM:

This is for SQL Server issues only:


The issue is where the Login Properties for innovator under server roles were set to:





The login server role should be set to public only.


Once I unchecked the other roles and had it set to public only, it didn't have this issue anymore.





piko - Tuesday, September 16, 2008 7:15 AM:


Did you find the solution to your problem? I'm facing the same one and got stucked with starting Aras.



V Manivannan - Thursday, July 16, 2015 6:27 AM:

Hi Marty Galvan,

 I selected the login server role only for public and It works fine for me.



Bill - Friday, October 3, 2008 3:46 PM:

I recieved no followup.  If you wish to tell me the details of your setup, I can extend the same offer to you.


sherenegladysj - Friday, June 5, 2009 10:00 AM:

Hi Bill and all,

Just noticed your discussion on this topic... the following is my system configuration

Sql Server: Express Edition 2005

WinXp with SP2

I am getting the following error while trying to login to Aras Innovator login page

"   Invalid object name 'LOCALE'   "

I am receiving this message no matter the user name & password is correct or wrong.

Have you come across such a scenario? Please help. Thanks in avance.

mmuthuka - Tuesday, September 15, 2009 3:50 PM:

I also got the same error message

Invalid Object Name LOCALE when i tried to login first time after installation.

Did you find any solution for the above problem?




Bill - Tuesday, September 15, 2009 5:30 PM:

I have never solved this issue through the forum.  However every time I have encountered this issue outside of the forum, the problem was that the database was installed with a DBA login like the default sa login.  This causes the database objects to have the wrong owner, and the SQL queires subsequently fail.

I recommend reinstalling, it will be fastest. just make sure to use a completely new login in the "Database Login Options".  You will need to manually delete the existing database before reinstalling.


sherenegladysj - Wednesday, September 16, 2009 1:46 AM:

Hello Selvi,

You are getting the error message because the username and Password is not set for the SQL Server. Database is not configured perfectly.

I resolved this issue by reinstallation of Aras. Please follow the Instructions carefully given in the pdf file while installing the Aras.

All the best...



francisco - Friday, September 24, 2010 10:10 AM:


I have received the same error when liging in for the first time. I have read your comments and I have a question:

Do you have to uninstall "Aras Innovator" from the control panel Add or Remove Programs?

Do you have to delete the database from SQL?

Please advice!

Thank you

francisco - Wednesday, October 6, 2010 5:21 PM:


If you were able to solve the problem by re installing the software, did you do any modification in SQL?

if so, what was it?

I just re installed the Aras software and got the same problem. I don't see instructions on how to install the SQL


Please advice.

Thank you