Install two instances of Aras V11 in the same machine

Hello All,


I have installed an instance of Aras Innovator V11 SP15 with the following url : http://MachineName/InnovatorServerOne/Client, using create a new database (dbOne) during installation.
what i want to do is adding or installing another instance (InnovatorServerTwo) of Aras V11 SP15 in the same machine using a database (dbTwo) that already exist.

Is there any idea please on how to add this second instance with the following url :http://MachineName/InnovatorServerTwo/Client  ?

Parents
  • Hello AJ Sebastian,

    I have done the needfull, the second instance installed successfully but i am unable to see changes when i execute a client Event method.

    Server event method works fine as when i execute the method i can see the changes.

    I have tested with a simple client method that contains just an alert but no changes are applied in the application. 

    Is there any missing configuration shoud be done ? as this is so strange

  • Hi Moaud,

    Assuming you're making/testing the changes in the same instance, I would recommend clearing your browser cache. It shouldn't make much of a difference unless you're modifying code tree files, however it's always one of my first steps when troubleshooting a client-side error or any strange behavior. 

    But to answer your question, there shouldn't be any additional requirements to have to parallel innovator instances running on one machine. Have you tried creating the client event in both instances? Does it work in one, both, or neither?

    AJ

  • Hi AJ Sebastian,

    I have tried creating the client event (alert) in the first instance already installed and it's works fine, but it's not working in the second instance as i didn't see any changes even if i clear the browser cache.

    Is there any other idea please ? as i'm still stuck on this.

  • Note that i have tried to add " debugger; " to the client method as you see in the screenshot below and nothing happens.

    but when i add the client method to the form (Part) of the itemType Part it's works fine with or without debugger option.

  • How are you executing the client method? What kind of client event are you attaching it to? Is it configured identically in the first instance?

  • Hi AJ Sebastian,
    the client method executed by clicking in the category concerned then the button   with the event onFormPopulated.

    Note that the IemType concerned is no longer displayed in the category in the TOC Pane and the list of categories does not show the category of the ItemType in question.

  • Issue resolved.

    Thanks

Reply Children
No Data