Import package 'com.aras.innovator.solution.QMS' failed


i have installed 12.0 SP7 and now trying to setup all applications.

Since the automatic installation using actual Aras Update utility is not working to setup any application (error ‘incompatible version of Innovator’), I use the manual method with Import tool of 12.0SP7.

After clean installation, I’ve successfully added newest PDF Viewer Package and Office Connector, both do work as expected.
Now I am working on the imports, I did it successfully in this sequence until I reach QMS package which fails:

  1. PE 12.0R2 (completed)
  2. PM 12.0R1 (completed)
  3. RE 12.0R2 (completed)
  4. CE 12.0R2 (completed)
  5. TD 12.0R1 (completed)
  6. QMS 12.0R1 -> here I run in an error, the import of ‘com.aras.innovator.solution.QMS ‘ failed at stage “Item 26 of 26: cmf_ContentType – Process Quality Document”, please check the abstract of the log as attached in QMS_Import_Error.log file, in line 929 the request fails (there is no document record of type PQD in my InnovatorSolutions DB).

Does anyone of you know how to resolve this issue, because my goal is to setup a complete Aras Innovator 12.0SP7 instance with all applications, now I stuck here, but need to setup the final 2 apps MPP, PQB. For both the QMS must be installed as requirement correctly, otherwise I am not able to continue.

Thank you

Best Regards



  • Hi Wolf,

    Looking at the logs, the error appears to be due to a timeout. This can happen occasionally for very long running queries. Could you try running the import again? 


    Christopher Gillis

    Aras Labs Software Engineer

  • Hi Chris,

    really? I've tried several times, also with two further environments, same issue. Server is usually performant with SSD and enough memory, and even the huge package of "component engineering" which imports much more data than QMS, did run through smoothly?!

    BR Wolf